Important Windows Server Security Update

On Friday, 14 April, the Shadow Brokers, a known hacker group, released hacking tools stolen from the United States’ National Security Agency (NSA).

These tools were designed by the NSA for their Equation Group, and are highly classified software built to be used on the systems of a wide range of major organisations, businesses, and governments.

You can read more about these tools on The Register.

With the release of these tools, anyone with a small amount of knowledge can exploit Windows machines, from Windows 2000 to Windows 8, as well as Server 2003 to Server 2012 R2.

Microsoft has released a series of updates over the past few months that block these tools from working. You can see the full list of exploits and the patches that stop them on Microsoft TechNet.

Because of these exploits, we urgently ask that you, as a Windows administrator, update your server. Please install the April Security Rollup, and reboot your server to install the updates fully.

We also ask that you please turn auto-update on to ensure that all Windows security patches are properly installed on your machine.

If you have further questions, or have noticed a problem with your server, please raise a ticket with your Account Control Panel.

This entry was posted in Cloud Next, Security, VPS. Bookmark the permalink.